My phone or tablet isn't supported.

Android

You can run Instagram on any camera phone with Android 2.2 or later with support for OpenGL ES 2, as well as tablets with support for OpenGL ES 2.

Things to keep in mind:

  • Phones without OpenGL ES 2, like the first generation HTC Wildfire, can't power Instagram's filters and can't be supported.
  • Phones running Android older than 2.2 can't power Instagram's filters.
  • There's a known issue with some Samsung Galaxy Y phones that causes posts to appear black on the filters screen and when it's uploaded. We're currently looking into this issue.

If you believe your phone should be compatible with Instagram, please let us know.

Apple iOS

Instagram v2.0 and later versions are supported on iOS 4.2.1 and later. If you're not running this version of iOS or later, you'll continue to see the old version of Instagram.

You can find your iOS version by opening your Settings and then tapping General > About.

Was this answer helpful? ·